Special setup information for Linux systems

(valid for version 1.1.x)

SikuliX
internally uses OpenCV to support the image related features and Tesseract for the text features.

On Linux/Unix systems one has to provide OpenCV 2.4+ and Tesseract 3.0.2+.
Additionally the packages wmctrl and xdotool are needed, which is used to implement the app related features.

On Linux systems based on the Debian package system (Debian, Ubuntu, ...) using the apt tools (apt-get to install a package) should do the job. On other Linux Systems (Fedora, RedHat, ...) you have to use the appropriate package manager, which in many cases should then be yum.
Read Moreā€¦